Skip to main content

Validate development standards

Suggest edit Updated on December 13, 2021

Enforce development standards on an application and manage the applicable development standards through policies. For more information on policies, see Managing development standards.

Note: If you violate any guardrail warning for a specified policy, the task fails.

This task is available in deployment and merge pipelines on Deployment Manager 4.8.5 and 5.4 or later.

Parameters

Input parameters

ParameterTypeDescription
Policy
Text
Run validation against this policy. Note: Enter the full policy name as this field does not support autocomplete.
Consider rules on or after create date
Date
Consider only rules created on or after the specified input date. Entered in yyyyMMdd format.
Consider only recently modified rule
True/false
Capture only rules in the most recent merge. This parameter is available only in deployment pipelines.

Output parameters

ParameterTypeDescription
Compliance report
Text
Contains the information that violates the enforced guardrail warnings in the policy specified as input.
Input for candidate
Text
Contains the details of the guardrail warnings that are validated on the candidate environment.
Did you find this content helpful? YesNo

Have a question? Get answers now.

Visit the Support Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us