Skip to main content

System requirements

Suggest edit Updated on October 12, 2021

This section describes the components that are required for a Pega Call installation.

Pega Call CTI Link for Cisco Finesse

Pega Call CTI Link for Cisco Finesse runs on a Pega Platform application server and provides CTI integration with Cisco Finesse. It provides telephony request processing that includes call control and agent state management. It also processes CTI events from Finesse, triggering changes such as screen pops within your Pega Call application. The CTI link uses the REST services and receives events from Finesse by using XMPP (Extensible Messaging and Presence Protocol) to connect to Cisco Finesse.

Other required components

In addition to the CTI link component requirements for Pega Platform, Pega Call CTI Link Engine requires Cisco Finesse version 11.0 or greater.

Cisco ECC variable configuration

If you want to transfer the Pega Customer Service interaction context when you transfer calls (for example, if you use the voice-data transfer feature) you must configure three expanded call context (ECC) variables in Cisco Finesse: userOldCallId, userOrigCallId, and userCPMInteractionID.

General requirements

For information on general hardware and software requirements for Pega Platform, see the Platform Support Guide on the Pega Community.

For more information about installing the Pega Call components, see Pega Call Installation and Update Guide.

Access settings for Pega Call rules and custom rulesets

If you use Pega Call with Pega Customer Service, the default application and access groups provided with Pega Customer Service include Pega Call capabilities.

Did you find this content helpful? YesNo

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us