Skip to main content

Enabling Next-Best-Action Designer version 2 to support multilevel configurations

Suggest edit Updated on January 19, 2022

If you already used Next-Best-Action Designer version 2 in versions of Pega Customer Decision Hub earlier than 8.5, after upgrading to Pega Customer Decision Hub 8.5, you must update your Next-Best-Action Designer configuration to support multilevel decisioning.

Pega Customer Decision Hub
  1. Ensure that no next-best-action outbound runs are active at moment and that no runs are planned for the same time frame as the Next-Best-Action Designer upgrade.
    Note: The upgrade can take 30-45 minutes.
  2. Ensure that no inbound requests, such as real-time event and real-time container requests, are planned for the same time frame as the Next-Best-Action Designer upgrade.
  3. Ensure that the Context Dictionary configuration is saved and valid.
  4. Ensure that the ruleset and version used by your access group are unlocked, or create an unlocked version of the ruleset. By default, the ruleset used to store the configuration is Artifacts.
  5. Optional: Check in all checked-out artifacts related to Next-Best-Action Designer to avoid potential issues during the upgrade.
  6. Optional: Lock and roll the Artifacts ruleset version. For more information, see https://community.pega.com/knowledgebase/articles/pega-cloud-services-post-upgrade-tasks-7x-8y/cloud/locking-and-rolling-ruleset-versions.
  7. Click Upgrade now.
  • Previous topic Upgrading Next-Best-Action Designer from version 1 to version 2
  • Next topic Importing Next-Best-Action settings from a template
Did you find this content helpful? YesNo

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us