Skip to main content

Updating an earlier version of Pega Customer Service

Suggest edit Updated on February 22, 2021

If updating an earlier version of Pega Customer Service, review the additional topics in this section.

Internet Explorer 11 not supported

In Pega Customer Service version 8.6, both Pega Customer Service and Pega Platform no longer support Internet Explorer 11. To use your application, use the Google Chrome, Firefox, or Microsoft Edge browsers.

Did you find this content helpful? YesNo

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us