Skip to main content

Updates to PD4ML support

Suggest edit Updated on June 3, 2022
Attention: This article is now available on the Pega Support Center:
Updates to PD4ML support

This article identifies improvements provided in the Pega Platform™ for HTML-to-PDF conversion with the PD4ML Library.

See the parent article, Troubleshooting HTML-to-PDF conversion issues.

Keeping current with Pega and PD4ML updates

PD4ML v4.0.9fx5 available in Pega Platform patch releases

Solutions

Keeping current with Pega and PD4ML updates

Best Practice: Keep current with Pega

To obtain a hotfix, follow these steps:

  1. Go to My Support Portal.
  2. For New Request, click For something I need.
  3. In the Service Request list, click Existing hotfix.
  4. Complete all fields of the form and Submit it.

PD4ML v4.0.9fx5 available in Pega Platform patch releases

Pega Platform patch releases have the latest version of PD4ML, currently PD4ML v4.0.9fx5.

If you need the latest version of PD4ML, upgrade to the latest Pega Platform patch release.

Pega updated the PD4ML version in patch releases for Pega Platform 8.4, Pega Platform 8.5, and Pega Platform 8.6. However, hotfixes are available if you need to continue using PD4ML v4.0.6 or move up to PD4ML 4.0.9fx5 for these versions.

Do not download the PD4ML.jar file from the vendor website.

Solutions

For the Pega Platform version that you are using, refer to the following table to get the latest PD4ML library that is supported for your Pega applications.

Alternative versions can be applied using the specified hotfix on the Pega Platform version to support either PD4ML v4.0.6 or PD4ML v4.0.9fx5.

If a hotfix is not available for a given Pega Platform patch release to support PD4ML, Pega will create a hotfix from a reported Incident (INC).

 
Pega Platform supported versions of PD4ML Library

Pega Platform Version

Patch Release

PD4ML Library Version

PD4ML v4.0.6
(alternative)

 

PD4ML v4.0.9 fx5
(alternative)

8.4

 

4.0.6

Not Applicable

Pega will provide a hotfix on service request INC.

 

8.4.1

4.0.6

Not Applicable

Pega will provide a hotfix on service request INC.

 

8.4.2

4.0.6

Not Applicable

Pega will provide a hotfix on service request INC.

 

8.4.3

4.0.9 fx1

HFIX-80020

Pega will provide a hotfix on service request INC.

 

8.4.4

4.0.9 fx3

HFIX-80300

HFIX-80485 

 

8.4.5

4.0.9 fx5

Not Applicable

Not Applicable

8.5

 

4.0.6

Not Applicable

Upgrade to Pega Platform 8.5.4.

 

8.5.1

4.0.6

Not Applicable

Upgrade to Pega Platform 8.5.4.

 

8.5.2

4.0.9 fx1

Pega will provide a hotfix on service request INC.

Upgrade to Pega Platform 8.5.4.

 

8.5.3

4.0.9 fx3

HFIX-80331

Upgrade to Pega Platform 8.5.4.

 

8.5.4

4.0.9 fx5

Pega will provide on service request INC.

Upgrade to Pega Platform 8.5.4.

 

8.5.5

4.0.9fx5

Pega will provide on service request INC.

 

8.6

 

4.0.9 fx3

HFIX-80746

HFIX-80747

 

8.6.1

4.0.9 fx5

Pega will provide on service request INC.

Not Applicable

8.7

 

4.0.9 fx5

Roll back is not recommended.

Updated guidance

  • Use compact CSS.
  • Use purpose-built HTML when needed.

Not Applicable

Did you find this content helpful? YesNo

100% found this useful

Have a question? Get answers now.

Visit the Support Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us