Skip to main content

Published Release Notes

Find release notes for the selected Pega Version and Capability

Browse resolved issues for Platform releases.

This documentation is for non-current versions of Pega Platform. For current release notes, go here.

Cassandra 3.11.3 support for Pega Platform

Valid from Pega Version 8.3

Increase your system's reliability and reduce its memory footprint by upgrading the internal Cassandra database to version 3.11.3.

For on-premises Pega Platform™ users, after you upgrade to Pega 8.3, it is recommended that you manually upgrade to Cassandra 3.11.3. You can upgrade to Cassandra 3.11.3 on all operating systems except IBM AIX. If you do not want to upgrade to Cassandra 3.11.3, you can continue to use Cassandra 2.1.20, which is still supported.

For Pega Cloud Services 2.13 and later versions, Cassandra automatically upgrades to version 3.11.3 after your environment is upgraded to Pega Platform 8.3.

For information on how to manually upgrade to Cassandra 3.11.3, see the Pega Platform 8.3 Upgrade Guide for your server and database at Deploy Pega Platform.

Upgrade impact

After an on-premises Pega Platform upgrade, you still have the older version of Cassandra and must manually upgrade.

What steps are required to update the application to be compatible with this change?

To upgrade Cassandra, you must create a prconfig setting or a dynamic system setting with the new Cassandra version and then do a rolling restart of all the Decision Data Store nodes to upgrade them to the latest version of Cassandra.

 

Text analytics models editing and versioning

Valid from Pega Version 8.3

Pega Platform™ now supports editing and updating training data for text analytics models.

Pega Platform also supports the versioning of text analytics models. When you update the model, Prediction Studio creates an updated model version. You can then switch between the model versions.

Upgrade impact

In versions of Pega Platform earlier than 8.3, the training data for text models was stored in the database. In Pega Platform version 8.3 and later, the training data for text models is stored in Pega Repository. You cannot build new models without setting the repository. After the repository is set, all text models are automatically upgraded and will work normally.

What steps are required to update the application to be compatible with this change?

After a successful upgrade, set the repository in Prediction Studio before building or updating any Natural Language Processing (NLP) models.  In Prediction Studio, click Settings > Text Model Data Repository.

 

For more information, see:

 

Text analytics models migration

Valid from Pega Version 8.3

Pega Platform™ now supports the exporting and importing of text analytics models. For example, you can export a model to a production system so that it can gather feedback data. You can then update the model with the collected feedback data to increase the model's accuracy.

Upgrade impact

In versions of Pega Platform earlier than 8.3, the training data for text models was stored in the database. In Pega Platform version 8.3 and later, the training data for text models is stored in Pega Repository. You cannot build new models without setting the repository. After the repository is set, all text models are automatically upgraded and will work normally.

What steps are required to update the application to be compatible with this change?

After a successful upgrade, set the repository in Prediction Studio before building or updating any Natural Language Processing (NLP) models.  In Prediction Studio, click Settings > Text Model Data Repository.

 

For more information, see:

Remove obsolete versions of the PredictiveAnalytics-UI and PredictiveAnalaytics-IntSvcs rulesets

Valid from Pega Version 7.2.2

After you upgrade the Pega 7 Platform to version 7.2.2, remove the PredictiveAnalytics-UI and PredictiveAnalytics-IntSvcs rulesets from your application as their versions are obsolete. Beginning with Pega 7.2.2, use the Pega-DecisionScience ruleset that contains the latest versions of the PredictiveAnalytics-UI and PredictiveAnalytics-IntSvcs rulesets.

For more information, see About ruleset versions.

Reconfiguration of the Adaptive Decision Manager service after upgrade to Pega 7.2.2

Valid from Pega Version 7.2.2

After you upgrade the Pega 7 Platform to version 7.2.2 from a version prior to 7.2,1, you need to configure the Adaptive Decision Manager service. Beginning with Pega 7.2.1, the Adaptive Decision Management (ADM) service is native to the Pega 7 Platform and is supported by the Decision data node infrastructure.

For more information, see Services landing page.

Set a time zone for the DateTime control

Valid from Pega Version 8.3

The DateTime control now supports the selection of a specific time zone. Apart from the default local time zone, you can choose a Java-supported time zone or enter a property. For example, you can make it easier for a manager working in New York to schedule a task for a worker in London by configuring a calendar picker on user forms to show a date and time for Europe/London.

Beginning with this release, the calendar picker defaults to the current time in the time zone that is defined in the operator record. Previously, it defaulted to the local time zone of the system.

For more information, see Specifying a time zone for a DateTime control.

Upgrade impact

After a successful upgrade, the DateTime gadget displays the time in the current operator's locale, which is defined on the operator rule form or in the browser.  

What steps are required to update the application to be compatible with this change?

If you need to display the system time from which the user has logged in, and if this is not the same as the time in the user's locale (based on the browser setting), set the Locale field in the operator ID to be blank so that the browser-based setting and the displayed time are the same as the system time.

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us