Skip to main content

Published Release Notes

Find release notes for the selected Pega Version and Capability

Browse resolved issues for Platform releases.

This documentation is for non-current versions of Pega Platform. For current release notes, go here.

Column Populator utility documentation out of date for prior versions

Valid from Pega Version 7.2

The documentation for using the Column Populator utility to populate newly exposed database columns is out of date for Pega 7 Platform versions prior to 7.2. For all Pega 7 versions, refer to the Pega 7.2 help documentation for instructions about how to use this utility.

Child case queries performance can be slow

Valid from Pega Version 7.2

Some customers have reported that performance is slow when they execute queries on child cases. This issue is often indicated by PEGA0005 (query time exceeded limit) alerts that can be correlated to these queries in the logs. To resolve the issue, add a database index to each of your work tables by using a multicolumn index on the pxCoverInsKey, pxObjClass, and pyStatusWork columns.

See Performance improvements for child case queries.

Verify ML Readiness error: Upgrades from Pega 7.1.0 through 7.1.8 do not replace nonversioned rules

Valid from Pega Version 7.2

Upgrading from any Pega 7 Platform version between Pega 7.1 and Pega 7.1.8 to Pega 7.2 does not automatically replace nonversioned rules. If you revalidated and saved a Pega 7.1.x rule after the timestamp on the Pega 7.2 version of the rule, upgrading to Pega 7.2 does not overwrite the saved rule. You might see either of the following behaviors:

  • The upgrade fails with the following error message:
    Verify ML Readiness
  • The upgrade succeeds, but you might be unable to open changed rule forms.

If the upgrade fails, see the Pega 7 Platform Upgrade Guide to force the upgrade.

This known issue does not affect Pega 7.1.9. After the upgrade has finished, apply Hotfix 27288. For information about obtaining and applying hotfixes, see Hotfix Manager.

System starts slowly after upgrade or update on IBM DB2 for z/OS

Valid from Pega Version 7.2.2

Additional tables are added to upgraded and updated systems. If your system starts up very slowly after an upgrade or update, the database statistics on these new tables might not have generated correctly. To correct this issue and improve performance, your database administrator needs to manually rebuild the statistics for all tables in the rules schema.

Clustering equal to none might cause errors

Valid from Pega Version 7.2.2

Some Pega 7 Platform features might not work when theidentification/cluster/protocolsetting in the prconfig.xml file is set to none. Some features that might not work are remote tracing and management actions on the node from the Requestor Management and Agent Management landing pages. Setting the clustering protocol to none is not recommended and will not be supported in a future Pega 7 Platform release.

Disregard this startup error for Oracle Weblogic deployments

Valid from Pega Version 7.2.2

If you install, upgrade, or update your Oracle Weblogic application server to Pega 7.2.2, disregard the error stack that begins with text similar to the following:

ERROR - WebLogic Server 12.1.3.0.0 Wed May 21 18:53:34 PDT 2014 1604337 Oracle WebLogic Server Module Dependencies 12.1 Tue Mar 11 15:35:15 MDT 2014 WebLogic Jersey Server Integration 3.0 Fri Feb 21 10:55:11 UTC 2014 must use JDK 1.8+ with WebSocket
2016-11-07 06:13:01,690 [ WIN-L3EEURCNCP1] [ STANDARD] (pr.DefaultAsyncSupportResolver) ERROR - Real error: Unable to configure jsr356 at that stage. ServerContainer is null

This message appears because the Pega 7.2.2 real-time notification feature initially tries to use WebSocket and then falls back to long polling. The Pega 7 Platform does not support WebSocket for Oracle Weblogic servers, and instead uses long polling for real-time notifications.

Disregard this Java script console message

Valid from Pega Version 7.2.2

Pega 7.2.2 introduced real-time notifications by using Comet technologies such as WebSocket and long polling. WebSocket provides the best results, but both WebSocket and non-blocking long polling must be supported by your application server. If your application server does not support WebSocket, you might see a JavaScript error that begins with text that is similar to the following text:

WebSocket connection to 'ws://vnbamdevapp01:8080/prweb/PRPushServlet/... Error during WebSocket handshake: Unexpected response code: 501_getWebSocket @ pzpega_ui_messaging_1802554968!!.js:1195 pzpega_ui_messaging_1802554968!!.js:3265 Websocket closed, reason: Connection was closed abnormally (that is, with no close frame being sent). - wasClean: falselog @ pzpega_ui_messaging_1802554968!!.js:3265 pzpega_ui_messaging_1802554968!!.js:3265 Websocket failed on first connection attempt. Downgrading to long-polling and resending

You can disregard this message.

However, to take advantage of the improvements to real-time notifications, enable support for WebSocket:

  • For IBM WebSphere Application Server Liberty Core, see your deployment guide for instructions on configuring the application server.
  • For Red Hat JBoss, see your deployment guide for instructions on enabling WebSocket support.
  • For Apache Tomcat application servers, consider upgrading to Apache Tomcat 7.0.53 or later which supports WebSocket.

prpcUtils script fails when the connection property file location is specified

Valid from Pega Version 7.2.2

If you run the prpcUtils command-line script and pass the --connPropFile argument to specify the location of the connection properties file, the script fails with the following error:

Problem: failed to create task or type ac:/antcontrib.org:for

This error does not appear if you do not pass the --connPropFile argument, or if you use the prpcServiceUtils scripts.

As a workaround, edit the prpcUtilsWrapper.xml file:

  1. Open <distribution>\scripts\utils\prpcUtilsWrapper.xml.
  2. Locate the following line:

    <taskdef resource="net/sf/antcontrib/antcontrib.properties" uri="ac:/antcontrib.org">

  3. Replace that line with the following line.

    <taskdef resource="net/sf/antcontrib/antlib.xml" uri="ac:/antcontrib.org">

  4. Save and close the file.

Data schema requires update after multitenant upgrade

Valid from Pega Version 7.2.2

After an out-of-place, multitenant upgrade to Pega 7.2.2 from Pega 7.2 or later, the PR_DATA_TAG_RELEVANTRECORD table that is in the existing data schema is not present in the new rules schema. The table must be present in the rules schema for the upgrade to the rules schema to work. Copy the PR_DATA_TAG_RELEVANTRECORD table from the existing data schema to the new rules schema, and then upgrade the new rules schema. The PR_DATA_TAG_RELEVANTRECORD table is not required to be in the rules schema. After the rules schema upgrade is finished, drop the copy of the table that is in the new rules schema before you upgrade the data schema.

Push notifications and Oracle WebLogic Server 10.3.6

Valid from Pega Version 7.2.2

Pega® Platform push notifications can use WebSockets and long polling. However, for WebLogic Server 10.3.6, the push notifications feature does not work. To disable the feature, contact Pegasystems Global Customer Support.

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us