Skip to main content

Published Release Notes

Find release notes for the selected Pega Version and Capability

Browse resolved issues for Platform releases.

This documentation is for non-current versions of Pega Platform. For current release notes, go here.

Specify the scope for rolling back rules and data to a restore point

Valid from Pega Version 8.4

Create restore points to save the state of all rules and data in your system at a significant point in time, for example, before you import an application. Roll back to that restore point to return the system to that state. Now, you can filter which rule and data instances are returned to their previous state:

  • System: Roll back every rule and data instance that has a history record.
  • User: Roll back rule and data instances modified by a specific user. If any rule was changed by more than one user, you will see an error message and must use the system rollback.
  • Application: Roll back rule and data instances in a specific application.

For more information, see Using restore points to enable error recovery.

Sign and encrypt signatures and content with additional algorithms

Valid from Pega Version 8.4

You can now authenticate using JSON Web Token (JWT) token profiles to symmetrically and asymmetrically encrypt both signatures and content. All algorithms in the Nimbus JWT library are supported, including nested tokens. Custom key identifier headers (kid) are also supported. Use token profiles to securely propagate identities and transfer data between systems.

For more information, see Creating a processing JSON Web token profile.

For more information, see Creating a generation JSON Web token profile.

Client-server deployment of Hazelcast

Valid from Pega Version 8.4

Pega Platform now supports the client-server model for the Hazelcast service, which provides cluster communication and distributes Pega Platform features across nodes. This optional deployment model introduces independent scalability for both servers and clients in Pega Platform, improving stability for deployments that use a large number of nodes.

The Hazelcast client-server model is intended for select environments running Pega Platform 8.4 across a large number of nodes and should be deployed only when directed by Global Client Support.

Expanded checks for Java injection vulnerabilities (8.4)

Valid from Pega Version 8.4

The Java injection vulnerability check feature has been enhanced in Pega Platform™ to further prevent Java injection, including Edit validate, Edit input, and JSP rules. Pega Platform reports errors at design time and run time, and does not run any rule that includes any of the following Java code:

  • JavaCompiler
  • new ProcessBuilder()
  • org.dita.dost.invoker
  • Runtime.getRuntime()

For more information, see Configuring the Java injection check.

Improved indexing performance by gradual retrieval of data

Valid from Pega Version 8.4

Search functionality in Pega Platform™ versions from 8.4.5 to 8.6 now includes the option to improve indexing performance when reading query results from a large table in a database. For example, to load the recommended 50 records at a time, in the Pega-SearchEngine ruleset, create the indexing/distributed/fetchsize dynamic system setting, and set the value to 50.


Creating the fetchsize dynamic system setting ensures that your system does not crash while indexing classes with numerous instances.

For more information, see Creating a dynamic system setting.

Supported JDBC drivers

Valid from Pega Version 7.1.1

Pega 7.1.1 supports Java 6 and Java 7 SDKs only. Ensure that the JDBC driver you are using supports those versions of Java. See your database installation or upgrade documentation for additional information.

DatabaseJava 6Java 7
Oracleojdbc6.jarojdbc7.jar
MSQLsqljdbc4.jarsqljdbc4.jar
DB2 LUWdb2jcc4.jardb2jcc4.jar
DB2 z/OS*db2jcc4.jar or jdb2jcc.jar**db2jcc4.jar
PostgreSQLpostgresql-9.1-903.jdbc4.jar***postgresql-9.1-903.jdbc4.jar

* JDBC drivers are only available from the DB2 for z/OS product. Additionally, you need db2jcc_license_cisuz.jar in the same directory as db2jcc4.jar.

** The db2jcc.jar has been deprecated and may not be supported in future releases.

*** This .jar file is required for PostgreSQL version 9.1.x.

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us