Skip to main content

Published Release Notes

Find release notes for the selected Pega Version and Capability

Browse resolved issues for Platform releases.

This documentation is for non-current versions of Pega Platform. For current release notes, go here.

Required Oracle optimization parameter

Valid from Pega Version 7.1.3

To optimize performance, set the Oracle parameter optimizer_index_cost_adj to a value between 20 and 25. If this value is not set, the system can run exceedingly slowly, potentially blocking users from login.

Synchronized database and application server settings

Valid from Pega Version 7.1.3

Configure your database and application server to use the same time zone and character encoding to avoid conflicts.

Use JDBC 4 compliant drivers for better performance

Valid from Pega Version 7.1.7

For better performance, ensure that you are using JDBC 4-compliant drivers.  For more information on supported and non-supported JDBC drivers, please reference the Platform Support Guide.

Use Tomcat 7 for better performance

Valid from Pega Version 7.1.7

For better performance with a Tomcat web server, use Tomcat 7.

Tomcat 6 has a limitation that causes the server to treat the JDBC driver as if it were a JDBC 3-compliant driver, even if the system is using a JDBC 4-compliant driver. Customers using Tomcat will see better performance if they upgrade to Tomcat 7 and use a JDBC 4-compliant driver.

Engine will not start if the incorrect JDBC driver is used

Valid from Pega Version 7.1.7

The engine will not start up if the incorrect JDBC driver is used. The following configurations are unsupported:

  • Using a Multi-tenant Oracle system with one of the Oracle JDBC drivers with issues (see the chart in the Platform Support Guide)
  • Using a Multi-tenant system with a JDBC 3 compliant driver, OR with Tomcat 6 (for more information on using tomcat with Pega 7.1.7, see Use Tomcat 7 for best performance)
  • Using Microsoft SQL Server with a JDBC 3 compliant driver, OR with Tomcat 6 (for more information on using tomcat with Pega 7.1.7, see Use Tomcat 7 for best performance)

When any of these unsupported configurations are encountered, Pega 7 will not start. Before this change, the engine would appear to start up properly, but would encounter issues during other parts of the engine startup or during actual use of the system.

Noticeable differences between work objects created in the Decision Manager portal when compared to Designer Studio

Valid from Pega Version 7.1.7

In the Decision Manager portal, you create work objects by running flows in the enterprise application that serves as the base application for the application overlay. If the enterprise application does not include the UI-Kit-7 in its application rulesets, work objects can display differently in the Decision Manager portal when compared to Designer Studio because an application overlay is always configured to include the UI-Kit-7 ruleset.

Recommendation:

  1. Add the UI-Kit-7 ruleset dependency to the enterprise application.
  2. Redesign the user interface to comply with the UI-Kit-7 ruleset.

IBM WebSphere Application Server V8: Edit the URL for Enabling System Management Application

Valid from Pega Version 7.1.7

WebSphere 8 does not correctly resolve the URL to enable System Management Application. As a workaround, when you configure the application server, you can do either of these actions:

  • Enter the full URL in the format:
    ​http://hostname:port/prsysmgmt/getnodes.action

  • Set the com.ibm.ws.webcontainer.redirectcontextroot property to true.

Rollback functionality is limited to latest revision

Valid from Pega Version 7.1.7

The rollback functionality in DSM Revision Manager allows customers to roll back the import of the latest revision to their DSM application. Only one rollback is allowed; after a rollback, the rollback option is disabled until the next revision is imported. If importing two (or more) revisions at once then attempting a rollback, the system only rolls back one revision.

Example: a user has a base DSM application. They import Revision 1, and then import Revision 2. Next, they try to roll back both revisions. The system reverts to the Revision 1 version of the application, and the customer cannot revert all the way back to the base application.

System Management Application displaying listeners that do not require any action

Valid from Pega Version 7.1.7

After installing or upgrading to Pega 7.1.7, there is an additional available listener (Data-Decision-DNode-Service:Default) that does not require any action. This listener can be safely ignored and you should not use the System Management Application to manage any of its operations or state.

  • The Data-Decision-DNode-Service:Default listener is always running on every PRPC node.
  • The state of this listener is internally managed by PRPC. Starting or stopping it through SMA does not have any effect on its state.

Open ports required for cluster communication

Valid from Pega Version 7.1.7

In a Pega 7 system, there can be multiple servers, or nodes, and each node can contain multiple JVMs.  In Pega 7.1.7, the port range 5701-5800 needs to be left open for cluster communication.   The number of available ports in this range needs to be greater than or equal to the greatest number of JVMs on any one node in the cluster.  So for example, if there are 3 JVMs on one node, and 7 JVMs on another node, there need to be at least 7 ports available.  By default, the system will begin with port 5701, and then look for the next port in the sequence (5702, followed by 5703).

 

If these ports are not available, you will see the following error:

 

ERROR   - PegaRULES initialization failed. Server: ABCDEF123

com.pega.pegarules.pub.context.InitializationFailedError: PRNodeImpl init failed

< . . . Java dump here . . . >

Caused by: com.hazelcast.core.HazelcastException: ServerSocket bind has failed. Hazelcast cannot start! config-port: <port>, latest-port: <port>

 

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us