Skip to main content

Published Release Notes

Find release notes for the selected Pega Version and Capability

Browse resolved issues for Platform releases.

This documentation is for non-current versions of Pega Platform. For current release notes, go here.

WSDL generation error prevents invocation of SOAP services

Valid from Pega Version 8.4.2

Status

A Known Issue was introduced in the 8.4.2 Pega Platform patch release, which impacts both upgrades and new installations of that version.

Description

Due to changes introduced in the SOAP functionality for the case-mismatch error in SR-D98509/INC-119725, the WSDL is being generated for SOAP services with an incorrectly-capitalized element, which prevents the service from being invoked.  The element should be “name” instead of “Name”.

Workaround

Clients must perform the following workaround after they define a new SOAP connector in Pega Platform:

  1. To download the WSDL from Pega Platform:
    1. After using the SOAP Wizard (Dev Studio > Configure > Integration > Services > Service Wizard) the WSDL URL is shown at the bottom right of the Dev Studio screen.
    2. Click the URL to display the XML.
    3. Save the WSDL file to your local system.
  2. In the text editor of your choice, modify "Name" to "name" in every <element “name” = … > tag in the WDSL.
  3. Save your changes to the local file.
  4. To reload the WSDL into Pega Platform:
    1. In Dev Studio, open the Configure menu.
    2. Select Integration > Connectors > Create SOAP Integration.
    3. In the New SOAP integration wizard, select Upload WSDL from File.
    4. Complete the upload using the wizard prompts.

This is a design-time issue, not a run-time issue; therefore, clients only have to perform this workaround process once. Existing SOAP services should not be impacted; however, if clients modify an existing SOAP service definition by re-running the wizard, clients must reapply the workaround for Pega Platform to recognize the SOAP definition changes.  

Resolution

This issue will be addressed in the Pega Platform Patch Release 8.4.3.  Clients who upgrade to that version or later should not see this issue.

Upgrading to the secure threading mechanism for email bots

Valid from Pega Version 8.1

In Pega Platform™ version 8.6, Pega Email Bot™ includes a more secure threading mechanism to help track emails from customers and other stakeholders in separate threads for an email triage case.

Upgrade impact

If you upgrade from Pega Platform version 8.5 or earlier, in which you configured an Email channel, perform the following steps to ensure that your system uses the new secure threading mechanism:

  • Update the service email rule that the system uses to send an email reply as the initial acknowledgment.
  • Update the email reply template in the data transform rule that the system uses when a customer service representative (CSR) sends the reply.

For more information about creating an initial acknowledgment email and email reply template, see Creating outbound email templates. For more information about the secure threading mechanism, see Use a secure threading mechanism in emails.

What steps are required to update the application to be compatible with this change?

For the initial acknowledgment email used by your email bot, update the service method for your email listener rule. On the Response tab for this service email rule, expand the Message contents section. In the Message data section, you specify the rule that defines the structure of the content of the email body. In Pega Platform version 8.6, you use for this purpose the pyEmailAcknowledgement correspondence rule that takes into account the selected built-in template. This template includes the security code tag that the system uses for the secure threading mechanism. If your application uses a different rule in the Message data section, update this definition to match one of the built-in correspondence template rules, for example, EmailAckTemplate_Clear.

The pySetEmailBotReplyTemplate data transform rule sets the name of the email correspondence rule that the system uses as the email reply template. If you do not want to use the default approach using the Classic, Cobalt, or Clear outbound email template themes, override this data transform rule to set the email correspondence rule name for the Param.ReplyTemplate target in the Source column field.

For more information about how to update the service email rule and the data transform rule to ensure that your system uses the secure threading mechanism, see Upgrading to the threading mechanism available in the 8.6 version.

Required Oracle optimization parameter

Valid from Pega Version 7.1.3

To optimize performance, set the Oracle parameter optimizer_index_cost_adj to a value between 20 and 25. If this value is not set, the system can run exceedingly slowly, potentially blocking users from login.

Split schema upgrade instructions missing properties

Valid from Pega Version 7.1.3

If you upgraded from 5.x, 6.x, or 7.x using the instructions in previous versions of the upgrade guide, you may have neglected to set the properties below in your migrateSystem.properties file when you migrated your upgraded schema to the source system:

 

pega.rules.objects.generate=true

pega.rules.objects.apply=true

 

If these properties were not set during an upgrade that splits the schema, your environment does not have the indexes, triggers, and primary keys on the rules tables.

 

To check for this issue, see if the pr4_base and pr4_rule rules tables in your existing rules schema are missing primary keys. If they are, use the SQL scripts in the ResourceKit\MigrationRecoveryScripts directory of the release to cleanup duplicate rules that were created due to this issue. Follow the steps below to run the scripts.

To run the scripts on Microsoft SQL, Oracle, or PostgreSLQ

  1. Take down any app servers using the affected schema.
  2. Backup your database.
  3. Replace all instances of @RULES_SCHEMA in <database>_cleanDups.sql with the name of the schema that contains the pr4_base table.
  4. Run the <database>_cleanDups.sql script on the database with vendor tools (sqlPlus, SQL Server Management Studio, etc).
  5. Replace all instances of @RULES_SCHEMA in <database>_fix_vw_table.sql with the name of the schema that contains the pr4_base table.
  6. Run the <database>_fix_vw_table.sql script on the database with vendor tools (sqlPlus, SQL Server Management Studio, etc).
  7. Generate and apply the ddl using the command line generateDDL command. Check the installation guide for your database or the upgrade guide for details about how to use the generateDDL command line script.
  8. Rebuild the indexes for the tables in your rules schema using vendor tools. This is necessary so that your system runs at an optimum speed.
  9. Optionally upgrade to the latest release, at this point your database is ready to be upgraded or used depending on your needs.

      

To run the scripts on DB2 for LUW or z/OS

  1. Take down any app servers using the affected schema.
  2. Backup your database.
  3. Run the <database>_cleanDups.sql script on the database with vendor tools (UDB CLP, Data Studio, etc) to create the CLEANSE_RULES_DUPS stored procedure.
  4. Run the query Call CLEANSE_RULES_DUPS(‘<rulesSchema>’); where <rulesSchema> is the name of schema that contains the pr4_base table.
  5. After the previous step is complete drop the CLEANSE_RULES_DUPS procedure.
  6. Replace all instances of @RULES_SCHEMA in <database>_fix_vw_table.sql with the name of the schema that contains the pr4_base table.
  7. Run the <database>_fix_vw_table.sql script on the database with vendor tools (UDB CLP, Data Studio, etc).
  8. Generate and apply the ddl using the command line generateDDL command. Check the installation guide for your database or the upgrade guide for details about how to use the generateDDL command line script.
  9. Rebuild the indexes for the tables in your rules schema using vendor tools. This is necessary so that your system runs at an optimum speed.
  10. Optionally upgrade to the latest release. At this point your database is ready to be upgraded or used depending on your needs.

Synchronized database and application server settings

Valid from Pega Version 7.1.3

Configure your database and application server to use the same time zone and character encoding to avoid conflicts.

Geolocation tracking requires browser permission

Valid from Pega Version 7.1.6

When the geolocation tracking feature is enabled, a Map it link appears next to each requestor entry in the audit trail. When you click a link for the first time, the browser displays a notification asking whether you want to permit tracking. Make your yes/no selection in the prompt. Do not click "X" to close it, as doing so may render the session unresponsive. Refresh the browser if necessary and make your selection.

Geolocation tracking Map it links do not appear

Valid from Pega Version 7.1.6

If geolocation tracking is enabled, the first time you create a case in the first browser session, the Map it links do not appear next to the initial audit trail entries. When you submit the first flow action, the links appear next to all subsequent entries.

Cannot copy final section rules in UI Kit ruleset

Valid from Pega Version 7.1.6

You cannot copy section rules in the UI Kit ruleset (UI-Kit-71) that start with pz or px (final rules in the base PRPC rulesets).

Instead, to customize these rules, use the Copy/Merge Ruleset tool, available at Designer Studio >System > Tools > Refactor Rulesets, to copy all rules from the UI Kit into your application ruleset. You can then check the section rules in and out.

User interface distortions in the Decision Manager portal

Valid from Pega Version 7.1.6

By default, the New Application wizard in Pega 7.1.6 configures new applications to include UI-Kit-7 in the list of application rulesets. This ruleset causes user interface distortions in the Decision Manager portal. Both applications created in previous maintenance level updates and applications created in Pega 7.1.6 that do not include the UI-Kit-7 dependency are not impacted by this known issue.

Workaround:

  1. Open the application record.
  2. In Application Rulesets, remove UI-Kit-7.
  3. Save the application record.

User interface distortions in the Predictive Analytics Director portal

Valid from Pega Version 7.1.6

By default, the New Application wizard configures new applications to include UI-Kit-7 in the list of application rulesets. This ruleset causes user interface distortions in the Predictive Analytics Director portal. Applications created in maintenance level updates previous to Pega 7.1.6, and applications that do not include the UI-Kit-7 dependency, are not impacted by this known issue.

Workaround:

  1. Open the application record.
  2. In Application Rulesets, remove UI-Kit-7.
  3. Save the application record.

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us