Skip to main content

Mashup code is not consistent with the latest security enhancements

Suggest edit
Updated on November 15, 2021

You might encounter issues with displaying mashups after an upgrade because of the latest security enhancements.

Condition

When the system receives a mashup request with the isWebMashup=true parameter and a blank channelID parameter, the system displays an error page with the following message: This mashup is not consistent with the latest security enhancements. Regenerate the mashup to include the channel ID in the snippet.

Cause

After an upgrade to Pega Platform 8.5, the system cannot load the existing mashups, which do not have the channel ID parameter in their code, and displays the access control warning.

Solution

  • Create a new mashup in your upgraded version of Pega Platform, and ensure that the data rule is included in your upgrade pipeline. As part of this process, generate the new mashup code, and redeploy it to the appropriate external websites to ensure that your mashups function as intended.

    For additional information, see Creating a mashup.

  • Previous topic Security warnings during mashup deployment
  • Next topic Modified parameters in the mashup code prevent access to the mashup channel
Did you find this content helpful? YesNo

0% found this useful

Have a question? Get answers now.

Visit the Support Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us